This site is currently viewing English for the USA

BT MeetMe with Dolby Voice

Your enhanced BT MeetMe service that will deliver more natural and effective audio meetings than traditional phone-based conference calls.

Looking for information on Dolby Conference Phone? You can find it here >

IT Administrator Guide

Please click here to download the latest IT Admin Guide >

Installation notes

Availability

As of June 2014 access to the service is permitted in the following countries:

Akrotiri, Albania, Angola, Argentina, Armenia, Australia, Austria, Azerbaijan, The Bahamas, Bahrain, Bangladesh, Belgium, Bolivia, Bosnia and Herzegovina, Brazil, Brunei, Bulgaria, Canada, Chile, China, Colombia, Costa Rica, Croatia, Cyprus, Czech Republic, Denmark, Dhekelia, Ecuador, El Salvador, Estonia, Faroe Islands, Finland, France, Georgia, Germany, Ghana, Hong Kong, Hungary, Iceland, India, Indonesia, Ireland, Isle of Man, Gibraltar, Greece, Greenland, Guam, Guatemala, Guernsey, Holy See (Vatican City), Israel, Italy, Jamaica, Jan Mayen, Japan, Jersey, Jordan, Kazakhstan, Korea South, Latvia, Lithuania, Luxembourg, Macedonia, Malaysia, Malta, Mexico, Monaco, Montenegro, Morocco, Netherlands, New Zealand, Nicaragua, Norway, Pakistan, Panama, Paraguay, Peru, Philippines, Poland, Portugal, Romania, Russia, San Marino, Singapore, Slovakia, Slovenia, South Africa, Spain, Sri Lanka, Svalbard, Sweden, Switzerland, Taiwan, Tajikistan, Thailand, Turkey, Turkmenistan, Ukraine, United Kingdom, United States, Uruguay, Uzbekistan, Venezuela, Vietnam, Zambia.

Web Plug-in System Requirements

Operating System and Web Browser support
Headsets

The following headsets have been tested by Dolby and approved to work optimally with the BT MeetMe with Dolby Voice plug-in:

  • Jabra®: BIZ 2400 Duo, Evolve 40 UC, UC Voice 750 Duo, UC Voice 550 Duo, BIZ 2300 Duo, BIZ 2400 II Duo, Evolve 30 Stereo
  • Logitech®: H650e
  • Microsoft: LX2000, LX3000
  • Plantronics®: C520, C520M, C320M, C720, C320, C325, C325 M, C725 M, Voyager Focus (Made for Dolby Voice)
  • Sennheiser®: SC60

Other headsets may work, but are not supported.

Mobile App System Requirements

The BT MeetMe with Dolby Voice mobile app supports the following mobile phone operating systems.

Support for Mobile Operating Systems
  • iOS support
    • 7.0, 7.1
    • 8.0, 8.1, 8.2, 8.3, 8.4
    • 9.0, 9.1
  • Android support
    • 4.2.x
    • 4.3.x
    • 4.4.x
    • 5.0
    • 5.0.2
    • 5.1
    • 6.0